Results 1 to 6 of 6

Thread: Shift Mode buttons acting up (xbox xontroller)

  1. #1
    Join Date
    Apr 2012
    Posts
    6

    Shift Mode buttons acting up (xbox xontroller)

    Hi all,

    I am playing SWTOR with my xbox controller, and mostly its going well. I used a predesigned profile either from Errol or Peeps from swtor forums (Errol knows who I mean) and reconfigured it a bit. I can't remember exactly which one I used, so I can't be more specific, sorry.

    First I had the trigger buttons set up as shift mode buttons, but when I used the right one it caused major bugs, returning to windows and switching between the swtor, pgp and desktop windows. It worked ok when I just pressed it to use as whatever I had assigned as the command (a target one I think), but when I held it it left SW and switched really fast between the windows as mentioned. I reassigned the shift mode buttons, and it hasn't happened again.

    Now that I have reassigned shift mode buttons to the bumpers, I am having new problems. I have the blue shift mode set up on the left bumper so it controls my companions abilities, which I often use to start a fight (he's my tank). I can't actually see which buttons are set as shift mode buttons, but I did set them as such and it tells me when I click on the behavious mod tab, so I think I used one of Errol's profiles which has the shift mode buttons hidden.

    What is happening now is that even once I release the bumper to leave shift mode, it seems to stay stuck in shift mode, and I can only use my companion's abilities. I have tried re clicking as well as holdning the bumper, but I can't exit this blue shift mode no matter what I try. Even though I have other things such as joysticks and mouse clicks mapped to be all the same in every mode, these controls lock up too while stuck in shift mode, and I just can't get the game to do anything. Even the keyboard and mouse lock up, and won't register mouse clicks or let me walk forward or back (only r/l strafe for some reason), or exit 'look' mode so I can move the mouse cursor on screen.

    I don't know if this is a swtor bug or a pgp bug, or something I have off in my profile setup, but if someone could help I would really appreciate it. I am more inclinded to think it is something I have done accidentally in PGP without realizing it (I only just started using it a week or so ago, still learning) because the same things keep happening each time with the same buttons. I just can't figure out what.

    I will include the profile I am using if I can figure out how.

    Thanks
    Regoria
    Attached Files Attached Files

  2. #2
    Join Date
    Apr 2012
    Posts
    6
    I tried fiddling with the settings in PGP and in SWTOR to make sure I hadn't done something wrong, but it still doesn't work. Whenever I use the left bumper (LB - rear button above trigger) on my xbox controller to so into shif mode so I can use my companion's abilities, it just stays stuck in companion abilities, stuck in the shift mode. I hold the button again and release, I click the button, I try using the keyboard, but none of these commands work. It is as if the computer is still holding down the control key (my keybindings to use [cont] + 1 through = for companion abilities) It will even turn the sound off when I try to walk, as these controls are auto bound [cont] a and [cont] d. I've checked everything I know how to do, and still I'm stuck. I even tried redoing the bindings in SWTOR in case that was the problem.

    PGP on my computer seems to be cut off slightly to the right for some reason. I can't see the very end of the commands written down the side, and can't see the behaviour modification shift mode symbol on either of the bumpers because there is no room for it to display. It displays when I had it as the triggers. I can tell that is it assigned to those keys though, because when I select the behav mod tab, it gives me the choice to remove shift mode, whihc it does not do if it is not assigned. I have included screenshots so you can see what I mean. *Sorry, I couldn't show screenshots, the file is too big

    I don't know what is going wrong, but I would like some help or at least feedback or any kind, to ask more questions or let me know you are looking into it. Not to be petty, but I have noticed several others posted questions in this forum after I did, and they have been answered. I am just anxious because I am at day 19 or 30 day trial, and I love this program when it works, but I will not purchase it if I cannot get it to work how it should, or get some help to see what I am doing wrong.

    Please, if anyone has any ideas, or some suggestions to try, I would be glad to hear them.

  3. #3
    Join Date
    Jul 2005
    Posts
    14,099
    I've tested your profile and I see what is happening... I have to do some more testing but I think there may be a bug that appears under certain timing situations.

  4. #4
    Join Date
    Jul 2005
    Posts
    14,099
    You'll be happy to know that I have found the bug and fixed it for the next release (which should be ready in about a week or two)

  5. #5
    Join Date
    Apr 2012
    Posts
    6
    Great, thanks so much Rob, I really appreciate it.

    I was really sad to see the news about Errol in another thread. I really hope he recovers completely, and send my love to his family and friends. If you were busy or preocupied with concerns for Errol, then I am really sorry, I think I came across as kinda demanding in my second post, which I did not mean to be. SWTOR is a very tricky and complex game, my first MMO, which I love but is a huge learning curve for me. I love it, but find it frustrating very often too. It was extra frustrating when the PGP controls weren't working porperly on top of the other issues I was having with learning the game. None of this is your fault, and I'm really sorry it I seemed rude in my last post. Especially considering the accident one of your important contributors had, and his subsequent serious health concerns. I really hope Errol is doing well.

  6. #6
    Join Date
    Dec 2010
    Location
    Trinidad W.I.
    Posts
    2,356
    Regoria thanks for the concern and words of comfort, I really do appreciate it very much.

    On another topic, I was reading on Peeps blog about you using PGP with SWTOR and you said your boyfriend wanted to use the PC. I have a suggestion, why don't you invest in another PC and you can play your games especially SWTOR. Right now PCs are very reasonably priced, the only thing that is expensive in a PC is the Hard Drive because of all the floods in Thailand, for they supply the world market with all the Hard Drives. Having your own PC will make you play your game without disturbances, for SWTOR is very time consuming. Anyway that was just a suggestion.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •